¿Cómo instalar IIS en Windows 7?

Hace ya tiempo que uso Windows 7 en su versión Beta como sistema operativo principal, lo descargue justo el mismo día que Microsoft anunciará su lanzamiento. No me he podido quejar de el, es bastante eficiente y rápido (y eso que uso 1GB en RAM), por el momento no me ha dado ningún problema de instalación de algún programa o incompatibilidad de hardware.

Siempre he usado Apache como servidor para correr mis sitios web, instalado desde paquetes como XAMPP o APPSERVER. Por motivo de mi Tesis (Mashup para los Servicios del SIABUC), tengo que tener instalado el IIS (Internet Information Services) para comunicarme a los servicios del SIABUC con SOAP / Web services. El problema es que no sabia que versión de IIS era la apropiada para Windows 7, ya que entraba al sitio oficial del IIS , y no me daba una versión especifica (como es el caso de Win XP).

Los pasos para instalar IIS en Windows 7 son los siguientes:
  1. INICIO > CONTROL PANEL > Programs and Features
  2. Dentro del cuadro de dialogo de Programs and Features, en la esquina superior izquierda, aparece Turn Windows features on or off.
  3. Click en Turn Windows features on or off, se abrirá otro cuadro de dialogo, dentro de este, aparecerá un listado de servicios.
  4. Selecciona (checkbox) Internet Information Services, y preciona OK.
  5. Se instalará el IIS, listo!

Para verificar si se ha instalado de forma correcta:

  1. Dentro de CONTROL PANEL, entramos a Administrative Tools.
  2. Aparecerá un cuadro de dialogo con los servicios del Win7, dentro de este se debe encontrar IIS Manager, si esta, pasamos al siguiente paso.
  3. Teclea en tu navegador (http://localhost/), si esta se abre, es la página por default de que esta corriendo de manera correcta el IIS.
OJO: Para todos aquellos que anteriormente tenian el APACHE, deben desactivarlo!, si no es asi, el IIS fallará en su inicio.

36 comentarios:

La_rudy dijo...

Hola muy bueno el post, te cuento, tengo Windows XP Colosus. Instale el IIS correctamente "Servicios de Internet Information Server (IIS)", es decir, aparece como componente. Sin embargo al abrir un nuevo explorardor y poner http://localhost me pide un usuario y contraseña de "colosus"... que tengo que poner alli?

Héctor Guedea dijo...

Hola @La_rudy, mira, podrian ser varios factores, podrías hacer lo siguiente:

1. Dentro del IIS Manager, hay que activar o desactivar ciertas opciones:

IIS > + Stitio Web > Click derecho en "Stitio web predeterminado" > Pestaña "Seguridad de directorios" > Click en "Modificar..."

IIS > + Stitio Web > Click derecho en "Stitio web predeterminado" > Pestaña "Seguridad de directorios" > Click en "Modificar..." activas las siguientes opciones:

Acceso anonimo
Permitir que IIS controle la contraseña

IMPORTANTE Desactiva: Autenticacion de Windows integrada


2. Si utilizas Firefox:

En Firefox escribe en la barra de direcciones:
about:config

En la lista que te aparece, busca:
network.automatic-ntlm-auth.trusted-uris

Dále dobleclick y escribe:
localhost


Espero que te sirva!, un saludo

La_rudy dijo...

Muchisimas gracias Héctor!!!!!!

Héctor Guedea dijo...

De nada Rudy, un saludote!

finitel dijo...

Hola de casualidad has creado algun formulario en la pagina que publicaste en iis? lo pregunto por que yo tengo mi pagina en windows 7 como lo explicas aca pero no se como tratar lo del formulario. Tengo hecho el formato campos de entrada y todo eso lo que me falta es configurar el form action que es lo que no entiendo, no lo quiero poner con mailto: por que alli sale outlok y casi nadie tiene eso configurado. Muchas gracias de antemano

Johan Bürk dijo...

Amigo, sin duda me has salvado con Win7, tube que habilitarlo para correr las herramientas de SQL Server.

Nos estamos mirando man.

Saludos

Héctor Guedea dijo...

Venga un saludo!

Adrián Mendoza García dijo...

Oye man una pregunta, como hago para poder correr los ASP's en IIS 7 de vista?

Héctor Guedea dijo...

Hola Adrián,
Cuando configuras el IIS te crea una carpeta en C:/ llamada NETPUT, dentro de ella encontrarás WWWROOT, bueno pues ahí es donde debes meter tus sitios web de ASP.

Un saludo!

Anónimo dijo...

Mil gracias hombre me ha servido su ayuda se agradece mucho.

Héctor Guedea dijo...

De nada un gran saludo!

michael dijo...

hola antes tenia el appserver pero lo desistale ahora lo quiero instalar de nuevo pero no sale nada cuando escribo localhost segui tus pasos pero me sale una pagina cuando escribo localhost mi sistema es windows 7 como lo puedo areglar de antemano gracias

responde a mi correo
peru_latino5@hotmail.com

Dios te vendiga

Insomniac dijo...

Gracias, me ayudaste bastante

KllR dijo...

Gracias, me resolviste rápido el problema.

Héctor Guedea dijo...

KIIR: De nada, un gran saludo!

Anni dijo...

GRACIAS! Me fuiste de mucha ayuda!

Anónimo dijo...

no me muestra nada
en el administrador/default web site-> encuentro que esta detenido y cuando lo quiero iniciar me tira un error: "El proceso no tiene acceso al archivo porque está siendo utilizado por otro proceso(Excepción de HRESULT:0x80070020)"

yelsi galvao dijo...

hola tambien digo yo..muy bueno el post...me a servido..gracias

Anónimo dijo...

Gracias!!!
(:

lil'Jose dijo...

excelente post!... demasiado util1... muchas gracias

Anónimo dijo...

Gracias..
tu post, me ayudado estaoy tratando de concectar una base de datos, a una pagina web y como soy un poco nueva en eso no me resultaba la conexion con el IIS como estoycomenzando a usar win7.. me ayudaste mucho gracias.
alicia

Anónimo dijo...

Hola Hector..., recien comienzo a utilizar el Windows 7 y tengo problemas para establecer la comunicación con un Web Services y una aplicacion hecha en Visual FoxPro que utiliza SOAP 3.0, me lanza el siguiente error:Connector: Unspecified HTTP error. HRESULT=0x800A1518. Ya instalé el IIS tal y como muy bien lo dices, pero continua el mensaje de error.
Te agradeceria que con tu experiencia, me indiques que esta mal por aqui. Te digo que esto sucede solo con Windows 7 pues hasta Windows Vista funcionó bien.

Un saludo desde Cuba

Edgar-V. dijo...

Holaa.!!
Muchas gracias muy buen post lo hize y sin ningun problemaa instale el componente IIS =) Lo probe siguendo los pasos que tu publicastes y listo
al 100% jeje... Saludos..

odiceo1 dijo...

Héctor saludos mi amigo, mira necesito su ayuda, veo en sus comentarios que le sabes a esto de la programación y a trabajar con IIS, yo soy odontólogo cubano que estoy aprendiendo trabajar con todo esto, tenia Windows xp y logre activar el IIS, estoy haciendo una historia clínica para odontología que trabaja con base de datos, estaba haciéndola en php y otros, pero un amigo me dio un trabajo súper adelantado en asp y visual basic, ahora tengo que aprender esto nuevo para mi, cambien para windows 7 y se me a formado tremendo rollo al activar IIS, en las características de Windows me salen una pila relacionadas con IIS, a parte sale algo como en núcleo de web para IIS también, dime si todo eso debe activarlo para que funcione, otra cosa, a ese proyecto tengo que hacerle muchas modificaciones, tengo que trabajar con base de datos, al instalar sql manager el que anteriormente tenia no es compatible con el Windows 7, descargue uno de Internet y cuando me se habré le doy a conectar me da error, mi hermano lo que se me a formado ha sido tremendo reguero, coji y desinstale todo, por favor guíame como hacer estoy bien, lo ultimo, en el xp un amigo que mas menos sabe al activar el IIS hacia un directorio virtual no hay forma de hacer eso bien, por favor te diré que se bastante poco de esto lo que me vallas a responder pónmelo desde cero, saludos y agradecería mucho su respuesta.

Anónimo dijo...

muy muy bueno, buen post gracias

huicho dijo...

gracias por el aporte me sirvio de mucho

Anónimo dijo...

hola men pues mira pare ser que aqui esta la solucion a mi problema espero que tu me puedas ayudar.. el problema es el siguiente:

estoy empesando en esto de .net y por consiguiente..

tengo visual estudio 2005. en el cual estoy trabajando para hacer una pagina web.. asta entonces todo vien pero aa me encontre con un datalle en en cual tengo que poner un link para poder dercargar un sistema operativo como puede ser el windows xp sp3..dicho windows lo tengo almacenado en una carpeta el mi pc que es la misma que quiero que funcione como servidor web..para no hacer mucho rrollo.. aber sii me puedes ayudar a poner mi pc como servidor para subir mi pagina web y de paso si hay que configurar algo en el vb.net..
de antemano apreisio tu ayuda ee no se si te pueda jear mi correo pero ai te ba
jesus_ami_88@hotmail.com

apresiaria aun mas su pronta respuesta

tania dijo...

This is a nice article..
Its very easy to understand ..
And this article is using to learn something about it..

Thanks a lot..!

bussines dijo...

Thanks very goord your post

Roberto Moreno dijo...

Me corre bien, entra a localhost y todo, hize un host en no-ip y lo agrega bien, pero al momento de darle click en el nombre del dominio, me abre la pagina de configuracion del modem.como cambio que me abra directamente la pagina sin entrar a la configuracion del modem?

Raúl dijo...

Que tal! quedó perfecto el IIS, pero ojalá que puedas ayudarme, lo instalé para hacer una prueba del módulo Web de SIABUC (leo que trabajaste en tu tesis sobre eso), y me marca un error similar al que me marca al rehacer la prueba en "varias" versiones de Apache: [client 127.0.0.1] malformed header from script. Bad header= < htm l>< body > < center > < h1 > No : web_s8.exe, referer: http://localhost/search.htm ... agardezco de antemano tu atención y ojalá puedas hecharme la mano!

Mastifal66 dijo...

Hola amigo que tal.., muy buen post me ha ayudado bastante solo tengo un problema te cuento.. soy aun estudiante y por razones de salud me he ausentado un tiempito de la U por lo que estoy muy retrasado...El proyecto se trata de inplementar en servidor en una intranet con IIS 7 en windows seven ya tengo todo listo de echo me conecto a la red y todo va bien... solo es que ahora tengo ke activar el servidor DNS y no se como... me gustaria que me orientara un poco en esto ya que realmente estoy con el tiempo encima... muchas gracias de antemano...

javier salas dijo...

En el Ultimate en español esta en elmismo lugar pero de lado derecho como activar o desactivar caracteristicas de windos, tampoco es necesario desintalar el apache o appserver con cambiarle el puerto a 8080 tienes trabajando los dos

Eduardo dijo...

Hola Hector espero me puedas ayudar... pues tngo el Win7,y tngo 2 dificultades que no puedo resolver 1ero es q cuando trato de crear un nuvo sitio en el DW_CS5 luego de ingresar todos los datos para la creacion del sitio me salta un mensaje "la carpeta raiz elegida es la misma que la carpeta del sitio 'BaseDatos'", el cual creo q ocasiona mi segundo pesar q es el de al tratar d visualizar las paginas .asp me sale este error "Error HTTP 401.3 - Unauthorized"...
desde ya, gracias por su respuesta...

...Eduardo

NARCISA DURAN dijo...

Hola yo estoy instalando el windows 7 ultimate pero no encuentro el iis cuando abro las caracteristicas de windows en activar o desactivar las caracteristicas de windows, no me aparece la opcion de IIs que podria ser es la primera vez que instalo el sistema operativo.

Anónimo dijo...

hola pude instalarlo pero en Herramientas administrativas no me aparece el IIS Manager. Me aparecio la carpeta inetpub y wwwroot pero no me funciona el localhost. Por que sera? Gracias y abrazos!